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File menu commands

The File menu offers the following commands:

New Creates a new Playing List.
Open Opens an existing playing-list or midi-file
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Exit Exits <<AWE Midi Player>>.



Option menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Configurati
on

Change program options

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Help 
Topics

Offers you an index to topics on which you can get help.

About Displays the version number of this application.



New Playing List Command (File menu)

Use this command to create a new Playing List in <<AWE Midi Player>>.

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing midi-file or playing-list in a new window.    You can 
open multiple documents at once.    Use the Window menu to switch among the multiple 
open documents.    See Window 1, 2, ... command.

You can create new playing-lists with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
      - MID files : Midi Files
      - LMI files : Playing Lists

Drives
Select the drive in which <<AWE Midi Player>> stores the file that you want to open. 

Directories
Select the directory in which <<AWE Midi Player>> stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close the window containing the active document.    <<AWE Midi 
Player>> suggests that you save changes to your document before you close it.    If you 
close a document without saving, you lose all changes made since the last time you saved 
it.    Before closing an untitled document, <<AWE Midi Player>> displays the Save As dialog 
box and suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, <<AWE Midi Player>> displays the Save As dialog 
box so you can name your document.    If you want to change the name and directory of an 
existing document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    <<AWE Midi Player>> displays 
the Save As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save your playing-list with a different name.
<<AWE Midi Player>> adds the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your <<AWE Midi Player>> session.    You can also use the Close 
command on the application Control menu.    <<AWE Midi Player>> prompts you to save 
documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on 
the clipboard.    This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This 
command is unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in <<AWE Midi Player>>, such as File Open.    A check mark 
appears next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in <<AWE Midi Player>>,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

<< Add or remove toolbar buttons from the list below according to which ones your 
application offers. >>

Click To

Creates a new empty playing-list.

Open an existing document.    <<AWE Midi Player>> displays the Open dialog box, in
which you can locate and open the desired file.

Save the active playing-list with its current name.    If you have not named the 
playing-list, <<AWE Midi Player>> displays the Save As dialog box.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the <<AWE Midi Player>> window.    To display 
or hide the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.



1, 2, ... command (Window menu)

<<AWE Midi Player>> displays a list of currently open document windows at the bottom of 
the Window menu.    A check mark appears in front of the document name of the active 
window.    Choose a document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using <<AWE Midi Player>> and various types of 
reference information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of <<AWE Midi 
Player>>.



Context Help command 

Use the Context Help command to obtain help on some portion of <<AWE Midi Player>>.    
When you choose the Toolbar's Context Help button, the mouse pointer will change to an 
arrow and question mark.    Then click somewhere in the <<AWE Midi Player>> window, 
such as another Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar
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The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button

Document Control-menu button

Maximize button

Minimize button

Name of the application

Name of the document

Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the <<AWE Midi Player>> window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    <<AWE Midi Player>> 
determines which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    <<AWE Midi 
Player>> determines which window is previous according to the order in which you opened 
the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the AweMid window or currently open dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Choose Font dialog box

<< Write application-specific help here. >>



Choose Color dialog box

<< Write application-specific help here. >>



Modifying the Document

<< Write application-specific help here that provides an overview of how the user should 
modify a document using your application.    

If your application supports multiple document types and you want to have a distinct help 
topic for each, then use the help context i.d. generated by running the MAKEHELP.BAT file 
produced by AppWizard.    Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the
help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the
first document type supported by your application.    AppWizard produces an alias in the .HPJ 
file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for 
that document type. >>





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>



Features

The purpose of this program is to play your favorite Midi-Files (*.MID). If you own a Sound-
Blaster AW32 or equivalent, the program can automatically load a set of Sound-Banks (*.SBK
or *.SF2) before playing each song.

Midi-Files especially composed for the AWE32 sound-card often come with a Sound-Bank that
has the same name as the .MID file, but with a .SF2 or .SBK extension.

The program searches for such a sound-bank in the same directory as the Midi-File, then in a
subdirectory you can specify yourself in the option dialog box (example: C:\SB16\SBK)

For a few Midi-Files, the default behaviour won't meet your needs, because the song may 
come with a set of Sound-Banks that have to be loaded simultaneously into the AWE32. 
Sometimes, many Midi-Files use the same Sound-Banks and the default behaviour will also 
be inadequate.

For all your special Sound-Bank needs, the program has a special dialog-box where you can 
associate up to 127 Sound-Banks with each Midi-File. Of course, AWE Midi Player will 
remember all the associations between sessions.

For each Midi-File, you can also set a new name, a Synth-Bank (GM, GS, MT-32 or USER), 
special effects settings (REVERB and CHORUS), and you can also modify the default volume. 
Volume setting is usefull in a Playing-List if one of your Midi-Files has an internal volume set 
too high.

With playing lists, you can drag&drop Midi-Files from the File-Manager or Explorer to the 
playing list window. You can also change the song sequence by clicking the number in front 
of the song name.



Debug Codes

AweMid32 is still a beta version and It has only been tested under Windows NT 3.51. It does 
NOT currently work under Windows 95 with the original driver shipped with Windows 95. 
Because there are many versions of the AWE Midi driver, under Windows NT and under 
Windows 95, I cannot test them all.

Anyway, the program will be tested and debugged under Windows 95 soon. If you cannot 
wait, you can experiment a few debug codes by modifying awemid32.ini that has not yet 
been moved to the registry for this reason.

AWEMID32.INI
[Debug]
Mask= <number>

The number is formed by bit-adding these flags:

DEBUG_VOLUME 1 The program doesn't issue midi volume commands
DEBUG_AWE 2 The program doesn't issue AWE specific commands
DEBUG_UBANKPATH 4 The program doesn't try to get the initial sound-bank 
state.

For example I think that the API I use to get the midi-volume and restore it on exit is not yet 
implemented in the Windows 95 version of the driver. Also, some drivers will crash if the 
program tries to get a sound-bank path. If you are in such a case, you add DEBUG_VOLUME 
and DEBUG_UBANKPATH:

[Debug]
Mask= 5.

If it still crashes but you want to see the program anyway, or if you don't have a Sound-
Blaster AWE32, add DEBUG_AWE to your Mask. In the previous example the resulting mask 
would be 7.

KNOWN BUGS:

- The repeat button on the playing-list doesn't work under NT 3.51
- The program crashes under W95 with the original driver, with no mask value in the debug 
section of the ini file. 
- The program cannot change the synth-bank and effect with some AWE32 drivers

KNOWN PROBLEMS:

- Many commands don't have an associated help topic .
- Set your Midi-Configuration to AWE32 ALL MIDI in the MidiMapper control panel applet if 
you don't hear all the tracks.

For any problem with this program, send a mail stating which version of the program you 
have, the OS you are using and which version of the AWE Midi driver you are using. (See the 
about box).
mailto://jmj@netsurf.org



Future improvements

- Fix for Windows 95.
- Fix for Windows NT 3.51 Playing-List Repeat Button.
- Fix of other not-yet-known bugs

- Command line parameters (eg awemid32 test.lmi /stop)
- Drag&Drop in the playing list to change the song order instead of the number to click.
- Keyboard Replacement for Drag&Drop (You must have a mouse today)
- Real Help file
- Others ....



Shareware

This program is not free nor public domain. It took me a very long time to learn 32-bit 
programming in C++ and to prepare the code for this program. Anyway, I did not put any 
limitation, like a time or feature limited version. It's up to you to stay morally in the legality 
by paying the program if you use it.

If you use it regulary, please send me the equivalent of $10 at the address specified bellow. 
This will morally help me to find some time in order to debug and improve the program. I will
listen to registered users first to code the improvements they need or find usefull. All 
registered users will also receive an EMail notification when a new version is released.

Jean-Michel Joudrier
24 rue Saint Louis

78760 PONTCHARTRAIN
FRANCE

Tel (+33-1) 45 88 13 58
Email: jmj@netsurf.org

WEB: http://www.netsurf.org/~jmj/

Enclose your name and your email address in your registration.

For any problem with this program, send a mail stating which version of the program you 
have, the OS you are using and which version of the AWE Midi driver you are using. (See the 
about box).
mailto://jmj@netsurf.org




